Dead Vanguard Board

So I came across a dead Vanguard that was for sale.  Described as only producing a boom sound effect and then a rumbling/static-y noise.  Bought the thing home along with 1.5 spare boards and did the usual checks: Power, Sockets (reseat), etc.  Logic probe on the CPU indicated that it was briefly running and then getting hung up and it looks like there is no watchdog on this game.  The sounds being made were from the sound board, which produces its noises without the main CPU being present at all.

Power takes a little longer than I would like to stabilize (several seconds), and was a tad low on the board, but adjusting it did not change anything.  It looks like the factory switching supply so it likely could use a cap job.

I got memory map information from MAME to try to figure out the memory map, and got a manual for the game.  The manual actually includes a memory map as well as which RAM chips are use in which RAM areas, which is really nice.

Connected up the Fluke 9010 and hit the Learn function.  When it was done, I noticed that the results did not match the memory map in the manual.  The first RAM section (CPU Work RAM) was not identified at all.  Turns out that section had stuck bits (2 & 3).  Replaced the socket and the RAM and the game mostly roared to life, with the exception of the power stabilization issue – it takes a few seconds after being initially powered on before the game will run stable so you have to cycle power several seconds after initially powering it up.  Monitor could use a cap kit but is in decent condition for its age.

Gonna hit that second board in the near future, initial tests show bit 8 is stuck high.

Comments are closed.